Hit pothole, buell blast died. Won't start. - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-13-2016, 01:35 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Location: colorado
Posts: 5
Hit pothole, buell blast died. Won't start.

Have a 2001 buell blast that I was riding and hit a huge pot hole jarring the whole bike. noticed engine died. lights and signals still were still on and working. checked the spark plug, but it's fairly new(Denso iridium power) didn't looked fowled but clean it up anyways. thought it might be ignition coil but changed that and nothing. thought maybe ignition control module, but the little red light still flickers when I crank it. I jumped the kickstand module also with no results. what else could it be???
Radrude is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome