starting problem HELP - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-03-2011, 05:51 PM Thread Starter
Junior Member
 
Join Date: Apr 2011
Posts: 1
starting problem HELP

2001 Blast . Turns over a couple times then starts clicking like a dead battery but I just bought new battery and I get the same thing. I noticed this starting at the end of last season and just assumed my battery was getting old. I just noticed from ebay when looking for a possible starter that these bikes have a starter relay - could this be the problem? any help appreciated

were is the starter relay located ?

Jon in Ohio
jmaxwdg is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-06-2011, 06:44 AM
Junior Member
 
Join Date: Apr 2011
Posts: 2
Sounds like you're having the same problem as me. If you find a solution can you let me know. Thanks, The Sherriff in Australia.
The Sherriff is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome