2002 Blast won't start - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-15-2014, 07:59 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Posts: 1
2002 Blast won't start

My girlfriend just purchased a 2002 Buell Blast. I picked it up and rode it ~45 minutes home and it ran okay (although a little rough idling). She wasn't able to see it for about a week and I didn't have any time to mess around with it and when she came to take it for a spin it wouldn't start.

I have brought the battery to Autozone and they say it checks good. When we try to start it all I get is a loud clicking (the starter?); the engine doesn't attempt to turn over at all.

Anyone have any ideas? I am used to working on dirtbikes, but am a bit foreign to the electrical systems of motorcycles, but want to give it a shot as best I can before having to take it somewhere.

Thanks!
justinS is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-21-2014, 08:41 AM
Super Moderator
 
compmoto's Avatar
 
Join Date: Jul 2012
Location: southern MD
Posts: 53
check the safety switches(kickstand,clutch lever,neutral,etc) all the starter safties(key,right handlebar switch,solenoid,battery connections,etc.) It definately sounds "electrical" in nature.. Let us know what you find ..

XB9S,EC300,RZ350
compmoto is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome