Need an Expert answer- Buell Blast power issues - Buell Forums: Buell Motorcycle Forum
 1Likes
  • 1 Post By Joshua Johnson
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-10-2018, 03:34 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 1
Post Need an Expert answer- Buell Blast power issues

Hi!!!

Just bought a 2003 Buell Blast, 1200 miles good condition. When I shift gears it is slow to increase speed and doesnt feel smooth. Also, the speedometer doesnt always register the speed. Yesterday I was in 3rd gear and it said I was going zero I was going at least 20mph! Please help!
Jasmine Sandler is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-08-2018, 12:03 PM
Junior Member
 
Join Date: Dec 2018
Posts: 1
The speedometer has a pigtail off the wire that goes into the transmission it’s 80$ but it will fix speedometer it’s the speed sensor
compmoto likes this.
Joshua Johnson is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome