Starter Switch Corrosion - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-10-2010, 02:19 PM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 1
Starter Switch Corrosion

Hi there!

New to working on my Buell and wanted to post a question I have.

My starter switch decided not to work last year. Took it to the shop and they said there is just some corrosion on the switch that needs to be rubbed off.

Same thing started to happen last week. Took apart the switch and didn't see any obvious marks of corrosion. Rubbed the ends a little bit and didn't notice any obvious difference.

Started just fine for three weeks.

Had the same problem today. Does anyone have any tips on how to clean this switch? What should I be looking for?

Thanks!
rlelewski is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome