2002 Buell Blast starting/idling issue - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-30-2012, 12:06 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 1
2002 Buell Blast starting/idling issue

Hey guys! I needed some help trouble shooting what I think is a carb issue. So this week I helped my dad get his first bike. It's a 2002 Buell Blast with a Vance & Hines exhaust on it. I don't think the last owner jetted the carbs for the exhaust because it backfires A LOT. If I let off the throttle and decelerate in gear it will just pop and pop and pop and friends riding behind can see the little flame from the exhaust when it's dark out.

Anyways, I test rode it before I bought it and it had a little trouble keeping the idle after starting up. I rode it up and down the street and it performed extremely well, I stopped at the sellers shop and let it sit and idle, which it did just fine for a couple minutes after the little test ride.

I went to pick it up the next day, It was near freezing out that night and it had a terrible time idling in the cold. My friend and the guy who sold it kept dicking around with the idle adjust until I said let me ride it, rode it up and down the street and it idled just fine, only at high RPM with all the adjustments they made. We adjusted it back down to a lower idle, and I rode it home about 40 miles, stopping to gas up along the way. It started back up fine after I gassed up and rode it home. It sat overnight in the cold which killed the battery so I replaced it the following day. It took a few tries to get it started and it had trouble staying at idle once I got it started. It rode fine, but you had to occasionally bump the throttle to keep it from dying. I went to tinker with it today and I can't get it to start. I'm going to try to bump the idle adjust up a little bit and see what happens, but I'm sure it will need at least a carb cleaning since it has been sitting for at least a year or so. Anyways, the biggest thing I am trying to figure out is how to troubleshoot the electric choke. The seller said he thought that might not be working right and that might be the cause so I want to find out how to check it and how it works etc. Otherwise, I haven't really played with a Buell before so any other advice and help is much appreciated. That bike is a TON of fun to ride.
puttputt is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-20-2014, 08:31 AM
Junior Member
 
Join Date: Apr 2014
Posts: 11
This post is*very*informative.*Thank you!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Estiodnatawe; 06-07-2014 at 06:37 AM.
Estiodnatawe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome