My Cyclone won't start - Buell Forums: Buell Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-17-2010, 02:57 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 2
My Cyclone won't start

I was parking my bike yesterday and let go of the clutch before I had my bike in neutral. The engine stalled out and when I tried starting it up again I get nothing. No clicking, no sound, no nothing when I press the electric starter. There was a constant stream of smoke coming from the engine after it stalled. Could it be the starter, spark plugs, wiring...? I imaging it is something electrical.

Any advise helps.

Thanks,

Justin
2000 Buell M2 Cyclone
Justin is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-25-2011, 09:11 PM
Junior Member
 
Join Date: Jul 2011
Posts: 2
Check you battery voltage if its good i'd try bypassing the kick stand switch.
wseaver5001 is offline  
post #3 of 3 (permalink) Old 10-28-2011, 03:58 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 2
Thanks for the good advice wseaver5001. Turns out my bike wouldn't start because it was still in first gear, my bike only starts in neutral, and the smoke was coming from some oil leaking onto my engine. Everything is working fine now. xD
Justin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buell Forums: Buell Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome